WQX Web Demo
Wide Format or Crosstab Parameters (Characteristic + Metadata) 
Wide format monitoring data arranges information so that each subject (e.g., monitoring station, device) has only one row, with multiple measurements or time points spread across columns. This format is often used for easier viewing in spreadsheets like Excel, although long format is generally preferred for data analysis. 
Here are examples of wide format monitoring data across different industries:
1. Environmental/Water Quality Monitoring 
In this example, each site is a single row, and various parameters (pH, Dissolved Oxygen) measured at different times are columns. 
	Station_ID 
	Date
	pH_0800
	pH_1200
	Temp_0800
	Temp_1200

	Site_A
	2025-01-01
	7.2
	7.5
	15.1
	16.2

	Site_B
	2025-01-01
	6.8
	6.9
	14.5
	14.8



Continuous Time Series Data are measured at different times as rows
	Station_ID 
	Date
	Time
	pH
	Temp

	Site_A
	2025-01-01
	08:00
	7.2
	15.1

	Site_A
	2025-01-01
	12:00
	7.5
	16.2

	Site_B
	2025-01-01
	08:00
	6.8
	14.5

	Site_B
	2025-01-01
	12:00
	6.9
	14.8



Key Characteristics of Wide Format
· One row per subject: Each entity (site, person, machine) appears only once.
· Time-series in columns: Observations made at different times or for different metrics occupy separate, unique columns.
· Human-readable: Often preferred for reports because it is easier to read and compare across columns.
· Disadvantage: Can make it difficult to perform certain statistical analyses that require "tidy" or "long" data

Our recommendation for continuous monitoring data is to report to WQX a single year or month activity in which you store the probe readings using up to 6 statistic summary events: daily / monthly average, max, min, median, standard deviation, and mode for a given day (no more than 6 actual daily events per line). In addition, data submitters should attach at the activity level a binary object formatted as plain text (".txt") file or compressed (".zip") file format for archiving the complete year / month raw set of probe readings downloaded from the data logger. This works equally well for the fixed data logger and for the so-called CTD cast, when the data logger is deployed off the side of a ship or pier and allowed to freely descend through the water column and report continuously the readings of its probes.

Activity and Result Metadata consist of both the minimum required schema elements and best practice for documentation your sampling results
Characteristics are specific, measurable indicators used to assess the state, performance, or quality of a system, such as water quality or environmental emissions. 
Key examples include pH, temperature, dissolved oxygen, pressure, and nutrient levels. These parameters allow for data-driven decisions and operational adjustments. 
Key Monitoring Parameter Examples: 
· Water Quality Parameters: is the chemical, physical, and biological, and radiological, characteristics of water, determining its safety for human consumption and ecosystem health. 
· Physical: Temperature, Turbidity, Conductivity.
· Chemical: pH (acidity/alkalinity), Dissolved Oxygen (DO), Nutrients (Total Nitrogen, Phosphorus), Metals, Chlorine, Peracetic Acid.
· Biological: E. coli, Bacteria, Algae.
· Environmental/Air Emissions Parameters: Crucial for tracking industrial pollution control.
· Operational: Temperature, Pressure, Flow Rate.
· Emissions: Particulate Matter (dust), Opacity.

Contextual Examples: 
· Water Sampling: Monitoring Nitrate (𝑁𝑂3) levels in a river to assess nutrient pollution.
· Emission Monitoring: Measuring baghouse pressure drop to ensure dust collector efficiency.

To calculate daily minimum, maximum, and average values in Excel, the most efficient method is using a Pivot Table. Select your data, go to Insert > Pivot Table, place dates in "Rows" and values in "Values," then right-click the values to select Summarize Values By (Min, Max, or Average). 

Method 1: Pivot Table (Fastest)
1. Select your table (Date column and Value column).
2. Go to Insert > PivotTable.
3. Drag the Date field to the Rows area.
4. Drag the Value field to the Values area three times.
5. Right-click the first Value column, select Summarize Values By > Min.
6. Right-click the second, select Max.
7. Right-click the third, select Average. 

Method 2: Formula Method (AVERAGEIFS/MAXIFS/MINIFS)
If you have a unique list of dates in Column E (starting at E2) and data in A2:B100 (Date in A, Value in B), use these formulas: 
· Daily Max: =MAXIFS(B$2:B$100, A$2:A$100, E2)
· Daily Min: =MINIFS(B$2:B$100, A$2:A$100, E2)
· Daily Average: =AVERAGEIFS(B$2:B$100, A$2:A$100, E2) 

To calculate daily minimum, maximum, and average values in Excel, the most efficient methods are Pivot Tables for quick analysis or MAXIFS, MINIFS, and AVERAGEIFS functions for dynamic reports. 
Here are the best methods based on your needs:
Method 1: Pivot Tables (Quickest & Recommended) 
This is the best method if you have a large dataset with hourly/timestamped data and need a summary table quickly. 
1. Prepare Data: Ensure your data has headers (e.g., "Date" and "Value").
2. Create Pivot Table: Go to the Insert tab and click PivotTable.
3. Setup Fields:
3. Drag the Date/Timestamp field into the Rows area.
3. Drag the Value field into the Values area three times.
4. Configure Calculations:
4. Right-click the first Value field in the table -> Summarize Values By -> Min.
4. Right-click the second Value field -> Summarize Values By -> Max.
4. Right-click the third Value field -> Summarize Values By -> Average.
5. Group by Day: If your timestamps are granular (date + time), right-click any date in the Pivot Table, select Group, and choose Days. 
Method 2: Formula-Based Approach (For Dynamic Reports)
If you need a list of unique dates and their corresponding metrics, use these formulas (available in Excel 2019/Office 365).
Assuming:
· Column A: Dates/Timestamps
· Column B: Values to calculate
· Cell D2: A specific date for which you want the calculation
· Daily Maximum: =MAXIFS(B:B, A:A, D2)
· Daily Minimum: =MINIFS(B:B, A:A, D2)
· Daily Average: =AVERAGEIFS(B:B, A:A, D2) 

Note: If your Date column includes times, create a helper column using =INT(A2) to extract just the date, and use that helper column in the formula criteria. 
Method 3: IF Array Formula (Older Excel Versions)
If you are using an older version of Excel that does not support MAXIFS/MINIFS, use these array formulas: 
1. Formula: =MAX(IF(DateRange=Date,ValueRange))
2. Important: Press Ctrl + Shift + Enter after typing the formula, not just Enter. 

Summary Table of Functions
	Metric 
	Function
	Example

	Minimum
	MINIFS
	=MINIFS(Values, Dates, "2023-01-01")

	Maximum
	MAXIFS
	=MAXIFS(Values, Dates, "2023-01-01")

	Average
	AVERAGEIFS
	=AVERAGEIFS(Values, Dates, "2023-01-01")


Quick Tips
· Unique Dates: To get a list of unique dates for your report, copy your date column, paste it elsewhere, and use Data > Remove Duplicates.
· AutoSum Shortcut: Highlight the cell range for a single day and click the arrow next to AutoSum on the Home tab to quickly select Average, Min, or Max. 

	PIVOT (B,G) 
PIVOT (Station,Date)
=B2 &"_"& G2
	Min (T)
Min (Value)
=MINIFS(T:T, B:B, B2, G:G, G2)
	Max (T)
Max (Value)
=MAXIFS(T:T, B:B, B2, G:G, G2)
	Avg (T)
Avg (Value)
=AVERAGEIFS(T:T, B:B, B2, G:G, G2)

	=B2 &"_"& G2
	=MINIFS(T:T, B:B, B2, G:G, G2)
	=MAXIFS(T:T, B:B, B2, G:G, G2)
	=AVERAGEIFS(T:T, B:B, B2, G:G, G2)



Creating a PivotTable in Excel acts as a "query builder" by allowing you to summarize, filter, and rearrange large datasets without writing formulas or code. The most advanced way to build these queries in Excel is through Power Query (to clean and shape data) and Power Pivot (to model data). 
Here is how to use Excel as a pivot table query builder:
1. The Standard PivotTable Query Builder (Basic)
1. Format Data: Ensure your data is in a proper tabular format (columns with headers, no empty rows/columns).
2. Create: Go to Insert > PivotTable.
3. Build (The "Query"): Use the PivotTable Fields pane to drag and drop fields into:
3. Rows/Columns: Define the dimensions of your report.
3. Values: Define the metrics to calculate (sum, count, average).
3. Filters: Restrict data to specific subsets. 
2. Power Query (For Data Transformation)
If your data is messy or spread across multiple sources, use Power Query to "build" the data structure first. 
1. Get Data: Go to the Data tab > Get Data (from File, Database, etc.).
2. Transform: In the Power Query Editor, you can:
2. Unpivot Columns: Turn columns into rows (crucial for transforming non-standard reports into a PivotTable-ready format).
2. Filter/Group: Filter out rows and group data to pre-summarize.
2. Merge/Append: Combine multiple tables.
3. Load: Click Close & Load to output the structured data into Excel, then create a PivotTable. 
3. Power Pivot (For Data Modeling)
For complex queries involving multiple related tables, use Power Pivot. 
1. Add to Model: When creating a PivotTable, check the box Add this data to the Data Model.
2. Manage Relationships: Go to the Power Pivot tab > Manage to define relationships between tables.
3. DAX Measures: Use Data Analysis Expressions (DAX) to create complex calculations (e.g., year-over-year growth) that act as advanced query metrics. 
Summary of Tools
· Power Query: Best for extracting, cleaning, and transforming data before analysis.
· PivotTable Field List: Best for quick drag-and-drop analysis.
· Power Pivot: Best for large datasets and modeling multiple, related tables. 
Key Tip: The best workflow is usually: Power Query (Clean) -> PivotTable (Analyze). This creates a repeatable, refreshable "query" pipeline.


SPREADSHEET EXAMPLES
1. BASIC: CROSSTAB2025 RAW DATA_ AWQAugust 2025 AWQ Data.xlsx
2. ADVANCED: CROSSTAB2025 RAW DATA_ NUTRIENT_ AWQ + Nutrients + PIB.xlsx
3. Summary MIN, MAX, AVERAGE physical/chemical (high frequency data): 
a. 5min: LONG2025.WSG Crab Team.WQX.7041.Results CSV.xlsx
b. RAW2025.WSG Crab Team.WQX.7041.Results CSV.xlsx
4. Translation Rules transform your data standard to WQX data standard
a. MONTHDATE#9258_PFAS from AXYS for Alex DSREH (TISSUE_NO)origkevinchristian
b. Import Configuration #9258
5. Continuous Template

Emailed guidance on CTD High frequency data

The Water Quality Exchange (WQX) database and Water Quality Portal warehouse services facilitate the sharing of water data. WQX and Water Quality Portal (WQP) are discrete sampling event services. This guide provides a high-level overview of best practices and recommendations for submitting continuous high-frequency data to the WQX dataflow. To ensure accurate storage, accessibility, and usability of water quality data include the following best practices. Key recommendations include submitting daily summary statistics and archiving raw data files as attachments to enhance data accessibility, visualization, and analysis.

Data submission Instructions
1. Remove RAW Continuous Datasets: If exists, remove the full RAW datasets of high frequency data for locations that have been previously uploaded and re-submit the same time frame as summary statistics with the RAW data as activity attachments based on the period of performance (Yearly, monthly, weekly, or daily).
1. Daily Summary Statistics: Submit daily summary statistics (e.g., average, max, min, median, standard deviation) for both surface and groundwater data. The daily statistics will be discoverable in the WQX schema and WQP results data profiles along with all other discrete samples and measurements. The dataowner may report in any stats supporting their analysis tools. This makes it easy to review and analyze the continuous daily data alongside any other sample data.
1. Data Storage Recommendations
1. Result Level Elements: Store data using schema elements: Analysis Start/End Date, Result Depth, Characteristic, etc.
1. Activity Level Elements: Store raw data files and operation periods using schema elements: Activity Start/End Date, ActivityAttachedBinaryObject, etc.
1. Attachments: can include both summarized (yearly, monthly, weekly, daily) and raw data archiving the full time-series records in plain text ”.txt”, “.csv” or compressed text .zip formats.
1. Data Summarization Tools – TEMPORARILY OFFLINE
1. EPA Continuous Data QC Tools (Click on Hyperlink)
0. ContDataSumVis R Shiny App
0. NALMS Shiny App

1. Recommended Statistics for Reporting
1. Summary Events: Report up to six statistics (e.g., average, max, min, median, standard deviation, mode).
1. File Formats: Archive raw data in plain text`.txt` or `.zip` formats for both fixed data loggers and CTD sensors.
1. WQX Submission Guidelines
1. ProjectID Assignment: Recommended to assign `ProjectID = "EPACONTINUOUS"` for continuous data identification.
0. For better support of data discoverability via Portal services which does not have filters by activity type to identify continuous data.
0. This project is created and owned by each organization to identify continuous data samples.
0. This ProjectID will be a national project via the Water Quality Portal

1. Activity Type Codes:
1. Field Msr/Obs-Continuous Time Series: Continuous measurements summarized as statistics.
1. Field Msr/Obs-Portable Data Logger: Short-term deployments (<2 weeks).
1. Sample-Integrated Time Series: Discrete samples derived from continuous data.
You can see examples and some limited guidance included with the continuous time-series template at the bottom of the following page: Water Quality Exchange Web Template Files | US EPA
WQX 3.0 - Template Continuous (Template) (zip)
The CTD typically also yields results for thermocline, halocline and pycnocline depths, which can be added to the results associated with the activity. An additional comment could be included to indicate that this activity is a fixed data logger. The activity information and the "Document/Graphic" file will be available on the Water Quality Portal after export to EPA.
Import Configuration:
	Element
	Type of Data

	.WQX 3.0 - Template Continuous (Template) ~ 7047
	Results & Activities



